summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm29
1 files changed, 16 insertions, 13 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 7423f3c6f1..3ad2cf4ea0 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -929,19 +929,22 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
 
 (define-public glibc-final
   ;; The final glibc, which embeds the statically-linked Bash built above.
-  (package-with-restricted-references
-   (package (inherit glibc-final-with-bootstrap-bash)
-     (name "glibc")
-     (inputs `(("static-bash" ,static-bash-for-glibc)
-               ,@(alist-delete
-                  "static-bash"
-                  (package-inputs glibc-final-with-bootstrap-bash)))))
-
-   ;; The final libc only refers to itself, but the 'debug' output contains
-   ;; references to GCC-BOOT0 and to the Linux headers.  XXX: Would be great
-   ;; if 'allowed-references' were per-output.
-   (cons* gcc-boot0 (linux-libre-headers-boot0)
-          (package-outputs glibc-final-with-bootstrap-bash))))
+  (package (inherit glibc-final-with-bootstrap-bash)
+    (name "glibc")
+    (inputs `(("static-bash" ,static-bash-for-glibc)
+              ,@(alist-delete
+                 "static-bash"
+                 (package-inputs glibc-final-with-bootstrap-bash))))
+
+    ;; The final libc only refers to itself, but the 'debug' output contains
+    ;; references to GCC-BOOT0 and to the Linux headers.  XXX: Would be great
+    ;; if 'allowed-references' were per-output.
+    (arguments
+     `(#:allowed-references
+       ,(cons* gcc-boot0 (linux-libre-headers-boot0)
+               (package-outputs glibc-final-with-bootstrap-bash))
+
+       ,@(package-arguments glibc-final-with-bootstrap-bash)))))
 
 (define gcc-boot0-wrapped
   ;; Make the cross-tools GCC-BOOT0 and BINUTILS-BOOT0 available under the