summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index a0f033305e..dd8518002d 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -116,11 +116,24 @@ remote applications.")
    ;; zlib libraries, so we need to propagate the inputs.
    (propagated-inputs `(("libgcrypt" ,libgcrypt)
                         ("zlib" ,zlib)))
-   (arguments '(#:configure-flags `("--with-libgcrypt")
-                #:phases (modify-phases %standard-phases
-                           (add-before 'configure 'autoreconf
-                             (lambda _
-                               (invoke "autoreconf" "-v"))))))
+   (arguments `(#:configure-flags `("--with-libgcrypt")
+                #:phases
+                ;; FIXME: In the next core-updates cycle, replace the entire
+                ;; following ,(...) form with its first 'modify-phases'
+                ;; subform.  The change made here is only strictly needed on
+                ;; MIPS, but should work on any system.  For now, we apply it
+                ;; only to MIPS to avoid forcing thousands of rebuilds on
+                ;; other systems.
+                ,(if (string-prefix? "mips" (or (%current-target-system)
+                                                (%current-system)))
+                     '(modify-phases %standard-phases
+                        (replace 'bootstrap
+                          (lambda _
+                            (invoke "autoreconf" "-v"))))
+                     '(modify-phases %standard-phases
+                        (add-before 'configure 'autoreconf
+                          (lambda _
+                            (invoke "autoreconf" "-v")))))))
    (native-inputs `(("autoconf" ,autoconf)
                     ("automake" ,automake)))
    (synopsis "Client-side C library implementing the SSH2 protocol")