summary refs log tree commit diff
path: root/nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix')
-rw-r--r--nix/libstore/globals.cc2
-rw-r--r--nix/local.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/nix/libstore/globals.cc b/nix/libstore/globals.cc
index 84fc885eba..65dad24d91 100644
--- a/nix/libstore/globals.cc
+++ b/nix/libstore/globals.cc
@@ -67,7 +67,7 @@ void Settings::processEnvironment()
     nixLogDir = canonPath(getEnv("NIX_LOG_DIR", NIX_LOG_DIR));
     nixStateDir = canonPath(getEnv("NIX_STATE_DIR", NIX_STATE_DIR));
     nixDBPath = getEnv("NIX_DB_DIR", nixStateDir + "/db");
-    nixConfDir = canonPath(getEnv("NIX_CONF_DIR", NIX_CONF_DIR));
+    nixConfDir = canonPath(getEnv("GUIX_CONFIGURATION_DIRECTORY", GUIX_CONFIGURATION_DIRECTORY));
     nixLibexecDir = canonPath(getEnv("NIX_LIBEXEC_DIR", NIX_LIBEXEC_DIR));
     nixBinDir = canonPath(getEnv("NIX_BIN_DIR", NIX_BIN_DIR));
     nixDaemonSocketFile = canonPath(nixStateDir + DEFAULT_SOCKET_PATH);
diff --git a/nix/local.mk b/nix/local.mk
index 07a92f74ea..b0e9bc1a2b 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -106,7 +106,7 @@ libstore_a_CPPFLAGS =				\
   -DNIX_DATA_DIR=\"$(datadir)\"			\
   -DNIX_STATE_DIR=\"$(localstatedir)/guix\"	\
   -DNIX_LOG_DIR=\"$(localstatedir)/log/guix\"	\
-  -DNIX_CONF_DIR=\"$(sysconfdir)/guix\"		\
+  -DGUIX_CONFIGURATION_DIRECTORY=\"$(sysconfdir)/guix\"		\
   -DNIX_LIBEXEC_DIR=\"$(libexecdir)\"		\
   -DNIX_BIN_DIR=\"$(bindir)\"			\
   -DOPENSSL_PATH="\"guix-authenticate\""	\