about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Nowack <m.nowack@imperial.ac.uk>2018-11-07 16:56:40 +0000
committerCristian Cadar <c.cadar@imperial.ac.uk>2018-12-14 11:03:03 +0000
commit124f8f688cfaa0c8ef8321d86064af216bb0e406 (patch)
tree286669cf87b4a20900187560fbe0a0ee7de7cea6 /CMakeLists.txt
parent0283175fdda6bf4dbd9343b53987d0aee01ce9fc (diff)
downloadklee-124f8f688cfaa0c8ef8321d86064af216bb0e406.tar.gz
Enable C++14 support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b1830954..3a41d0f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -291,9 +291,9 @@ endif()
 # C++ version
 ################################################################################
 if ("${CMAKE_VERSION}" VERSION_LESS "3.1")
-  add_global_cxx_flag("-std=c++11" REQUIRED)
+  add_global_cxx_flag("-std=c++14" REQUIRED)
 else ()
-  set(CMAKE_CXX_STANDARD 11)
+  set(CMAKE_CXX_STANDARD 14)
   set(CMAKE_CXX_STANDARD_REQUIRED ON)
 endif ()