about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrank Busse <bb0xfb@gmail.com>2022-03-18 09:06:48 +0000
committerMartinNowack <2443641+MartinNowack@users.noreply.github.com>2022-04-25 18:13:56 +0100
commit33bac31837938c0fdc143022ae8498beb57510a8 (patch)
treed8018c568ae1d44599504500ed86b624468582c8 /CMakeLists.txt
parentee94e78a5bde3b491282db7acf1620c224119459 (diff)
downloadklee-33bac31837938c0fdc143022ae8498beb57510a8.tar.gz
use mallinfo2 if available
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 728bf922..a92c2f2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -409,6 +409,7 @@ endif (HAVE_PTY_H OR HAVE_UTIL_H OR HAVE_LIBUTIL_H)
 ################################################################################
 check_cxx_symbol_exists(__ctype_b_loc ctype.h HAVE_CTYPE_EXTERNALS)
 check_cxx_symbol_exists(mallinfo malloc.h HAVE_MALLINFO)
+check_cxx_symbol_exists(mallinfo2 malloc.h HAVE_MALLINFO2)
 check_cxx_symbol_exists(malloc_zone_statistics malloc/malloc.h HAVE_MALLOC_ZONE_STATISTICS)
 
 check_include_file(sys/statfs.h HAVE_SYSSTATFS_H)