about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjiseongg <jiseongg301@gmail.com>2021-01-16 15:14:06 +0900
committerMartinNowack <2443641+MartinNowack@users.noreply.github.com>2021-03-05 22:03:13 +0000
commit36780583dd78865100114b02627a3418b2d56deb (patch)
tree5d8ed323aba94e01211fe7e1439a4c1ca118eed0 /CMakeLists.txt
parentb1ef0c8a7bd433b81c057ecad656608a82a3b7dc (diff)
downloadklee-36780583dd78865100114b02627a3418b2d56deb.tar.gz
Add cmake custom target `uninstall`
`make uninstall` is enabled.
Without this, uninstalling was done manually with `rm` command.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5e5d4aa1..1d00d7f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -814,3 +814,19 @@ endif()
 # Miscellaneous install
 ################################################################################
 install(FILES include/klee/klee.h DESTINATION include/klee)
+
+################################################################################
+# Uninstall rule
+################################################################################
+configure_file(
+  "${PROJECT_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in"
+  "${CMAKE_BINARY_DIR}/cmake_uninstall.cmake"
+	@ONLY
+)
+
+add_custom_target(uninstall
+  COMMAND
+  "${CMAKE_COMMAND}" -P "${CMAKE_BINARY_DIR}/cmake_uninstall.cmake"
+  COMMENT "Uninstalling..."
+  VERBATIM
+)