about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Nowack <m.nowack@imperial.ac.uk>2023-03-22 10:37:11 +0000
committerCristian Cadar <c.cadar@imperial.ac.uk>2023-03-22 19:53:20 +0000
commit3a0e434dc9d4053d75e9c0bbe6faa6dfb46717ae (patch)
treefe4e7f2111288bb14156c704af88b616a11375b3 /CMakeLists.txt
parent8dcd69dda61c58e9fb5bc392c9e5f787fee0a5b6 (diff)
downloadklee-3a0e434dc9d4053d75e9c0bbe6faa6dfb46717ae.tar.gz
Require minimal version of CMake 3.16 for KLEE
This is the default version for Ubuntu 20.04 and should be available
for most distributions.

Moreover this should allow to move STP forward with their changes.

(https://github.com/stp/stp/issues/375#issuecomment-889178863)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59c6094a..54be2d3d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@
 ###############################################################################
 # Minimum CMake version and policies
 ###############################################################################
-cmake_minimum_required(VERSION 3.9.0)
+cmake_minimum_required(VERSION 3.16.0)
 project(KLEE CXX C)
 
 ###############################################################################