about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimotej Kapus <tk1713@ic.ac.uk>2018-10-28 12:49:52 +0000
committerMartinNowack <martin.nowack@gmail.com>2019-04-04 20:37:41 +0100
commit572d644e8de439fe59f5598fc902d71b60cf8a85 (patch)
tree2b6a06d02c2854efc7f916121ef950c75438e325 /CMakeLists.txt
parentb1f34f8d0ff890511e16fc322abf3ca08000b950 (diff)
downloadklee-572d644e8de439fe59f5598fc902d71b60cf8a85.tar.gz
Clean klee-stats, StatsTracker and cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30a7292c..ebcbe6f6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -416,6 +416,16 @@ else()
 endif()
 
 ################################################################################
+# Detect SQLite3
+################################################################################
+find_package(SQLite3)
+if (SQLITE3_FOUND)
+  include_directories(${SQLITE3_INCLUDE_DIRS})
+else()
+    message( FATAL_ERROR "SQLite3 not found, please install" )
+endif()
+
+################################################################################
 # Detect libcap
 ################################################################################
 check_include_file("sys/capability.h" HAVE_SYS_CAPABILITY_H)