about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Büning <julian.buening@comsys.rwth-aachen.de>2023-05-29 18:14:30 +0200
committerCristian Cadar <c.cadar@imperial.ac.uk>2023-06-05 17:04:19 +0100
commit58fb505496b0bae75a300f618cd6e7279a460e95 (patch)
tree70d20a4b064edb0785216e8d648db8b7ca995415 /CMakeLists.txt
parenta1665020e9ab501eedc7b5b77f9f0fe0ccc69317 (diff)
downloadklee-58fb505496b0bae75a300f618cd6e7279a460e95.tar.gz
config.h: include FSTATAT_PATH_ACCEPTS_NULL
This variable was introduced by d2f5906da4ae37a41ae257e5308d50e19689877b
but not included in `config.h` before. As a result `#ifdef` would always
fail. Moving the code is necessary to set the variable before `config.h`
is created using `configure_file()` in CMakeLists.txt.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8ce0d16..552d431a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -394,12 +394,16 @@ else()
   set(HAVE_SELINUX 0)
 endif()
 
+try_compile (FSTATAT_PATH_ACCEPTS_NULL
+  ${CMAKE_BINARY_DIR}
+  ${PROJECT_SOURCE_DIR}/cmake/fstatat.c
+)
+
 ################################################################################
 # KLEE runtime support
 ################################################################################
 # This is set here and not in `runtime` because `config.h` needs to be generated.
 
-
 set(available_klee_runtime_build_types
   "Release"
   "Release+Debug"