about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Nowack <m.nowack@imperial.ac.uk>2023-03-20 17:50:30 +0000
committerCristian Cadar <c.cadar@imperial.ac.uk>2023-03-22 17:02:03 +0000
commit5c8610ec5e6fd54746b2934bcb0a4d63ef20b0bf (patch)
tree2b8f8fbe82f4c5fa56dc52c1524dc42edb90fce9 /CMakeLists.txt
parent1398e960ec9aca3f0ceac5e37062631986b9c2a8 (diff)
downloadklee-5c8610ec5e6fd54746b2934bcb0a4d63ef20b0bf.tar.gz
Explicitly check if 32bit support is enabled for testing
Ignore test in the first place, if no 32bit is enabled.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf01df24..59c6094a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -430,8 +430,14 @@ message(STATUS "KLEE_RUNTIME_BUILD_TYPE: ${KLEE_RUNTIME_BUILD_TYPE}")
 include(CheckCSourceRuns)
 cmake_push_check_state()
 set(CMAKE_REQUIRED_FLAGS "-m32")
-check_c_source_runs("int main(int argc, char** argv){return 0;}" M32_SUPPORTED)
+check_c_source_runs("int main(int argc, char** argv){return 0;}" CHECK_M32_SUPPORT)
 cmake_pop_check_state()
+if (NOT CHECK_M32_SUPPORT)
+  set(M32_SUPPORTED 0)
+else()
+  set(M32_SUPPORTED 1)
+endif()
+
 message(STATUS "32bit platform supported: ${M32_SUPPORTED}")
 
 set(KLEE_INSTALL_RUNTIME_DIR "${CMAKE_INSTALL_FULL_LIBDIR}/klee/runtime")