about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrank Busse <bb0xfb@gmail.com>2022-06-13 10:42:51 +0100
committerMartinNowack <2443641+MartinNowack@users.noreply.github.com>2022-06-30 10:02:30 +0100
commit6cc8ee707c1b4337120aa2972e2ad13a4861bbc3 (patch)
tree52aa6fc4f793239963679550e673b6f3a18c3e71 /CMakeLists.txt
parentb8539333fdaf32b0f4911d6569ad56a0443190bb (diff)
downloadklee-6cc8ee707c1b4337120aa2972e2ad13a4861bbc3.tar.gz
remove LLVM < 9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 2 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16e33ea9..89054a86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -455,11 +455,6 @@ else()
 endif()
 
 ################################################################################
-# Workarounds
-################################################################################
-include(${CMAKE_SOURCE_DIR}/cmake/workaround_llvm_pr39177.cmake)
-
-################################################################################
 # KLEE runtime support
 ################################################################################
 # This is set here and not in `runtime` because `config.h` needs to be generated.
@@ -612,13 +607,8 @@ if (ENABLE_KLEE_EH_CXX)
   endif()
   message(STATUS "Use libc++abi source path: \"${KLEE_LIBCXXABI_SRC_DIR}\"")
 
-  if (${LLVM_VERSION_MAJOR} GREATER 8 OR ${LLVM_VERSION_MAJOR} EQUAL 8)
-    set(SUPPORT_KLEE_EH_CXX 1) # For config.h
-    message(STATUS "Support for C++ Exceptions enabled")
-  else()
-    set(SUPPORT_KLEE_EH_CXX 0) # For config.h
-    message(STATUS "Support for C++ Exceptions (only available for LLVM >= 8.0.0) disabled")
-  endif()
+  set(SUPPORT_KLEE_EH_CXX 1) # For config.h
+  message(STATUS "Support for C++ Exceptions enabled")
 
 else()
   set(SUPPORT_KLEE_EH_CXX 0) # For config.h