about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Nowack <m.nowack@imperial.ac.uk>2019-03-10 14:09:24 +0000
committerCristian Cadar <c.cadar@imperial.ac.uk>2019-03-12 16:41:27 +0000
commit74c432e6c46f4c570a14b46346b208aeb8b5e0fa (patch)
tree24c1d8f4e862c6f4f86217fe2d159c1e987617b8 /CMakeLists.txt
parente4129c4c780cc4476ecc65ec13ab8399a3bd9778 (diff)
downloadklee-74c432e6c46f4c570a14b46346b208aeb8b5e0fa.tar.gz
Add support to compile KLEE with MemorySanitizer (MSan)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 164ce1a1..b40b9414 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -617,12 +617,15 @@ endif()
 message(STATUS "${CMAKE_CXX_FLAGS}")
 set(IS_ASAN_BUILD 0)
 set(IS_UBSAN_BUILD 0)
+set(IS_MSAN_BUILD 0)
 string(REPLACE " " ";" _flags ${CMAKE_CXX_FLAGS})
 foreach(arg IN ITEMS ${_flags})
   if (${arg} STREQUAL -fsanitize=address)
     set(IS_ASAN_BUILD 1)
   elseif (${arg} STREQUAL -fsanitize=undefined)
     set(IS_UBSAN_BUILD 1)
+  elseif (${arg} STREQUAL -fsanitize=memory)
+    set(IS_MSAN_BUILD 1)
   endif()
 endforeach()
 unset(_flags)