about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLukas Zaoral <lzaoral@redhat.com>2021-03-04 13:30:11 +0100
committerMartinNowack <2443641+MartinNowack@users.noreply.github.com>2021-03-04 20:40:58 +0000
commit91420b32cd347b43f64d337e5bd1f0855d0b247c (patch)
tree6c98069b6cd72ed4c0678a9d4ac5ffa800c0a23a /CMakeLists.txt
parent295353010d23c9561826f811a59b7d5556c45596 (diff)
downloadklee-91420b32cd347b43f64d337e5bd1f0855d0b247c.tar.gz
cmake: Fix warning about implicit type conversion
Fixes:
CMake Warning (dev) at CMakeLists.txt:478 (set):
  implicitly converting 'String' to 'STRING' type.
This warning is for project developers.  Use -Wno-dev to suppress it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a37d5f0b..5e5d4aa1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,7 +72,7 @@ else()
   if(NOT CMAKE_BUILD_TYPE)
     message(STATUS "CMAKE_BUILD_TYPE is not set. Setting default")
     message(STATUS "The available build types are: ${available_build_types}")
-    set(CMAKE_BUILD_TYPE RelWithDebInfo CACHE String
+    set(CMAKE_BUILD_TYPE RelWithDebInfo CACHE STRING
         "Options are ${available_build_types}"
         FORCE)
     # Provide drop down menu options in cmake-gui
@@ -475,7 +475,7 @@ set(available_klee_runtime_build_types
 if (NOT KLEE_RUNTIME_BUILD_TYPE)
   message(STATUS "KLEE_RUNTIME_BUILD_TYPE is not set. Setting default")
   message(STATUS "The available runtime build types are: ${available_klee_runtime_build_types}")
-  set(KLEE_RUNTIME_BUILD_TYPE "Debug+Asserts" CACHE String
+  set(KLEE_RUNTIME_BUILD_TYPE "Debug+Asserts" CACHE STRING
     "Options are ${available_klee_runtime_build_types}"
     FORCE)
 endif()