about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Liew <daniel.liew@imperial.ac.uk>2016-11-30 15:48:46 +0000
committerDan Liew <daniel.liew@imperial.ac.uk>2016-11-30 15:48:46 +0000
commit9be96537af07b1f03a55550b932df6f5397c9e6b (patch)
treebaf21aaac9305fa2f52bdca50b1f040945a91fab /CMakeLists.txt
parent82c9bb332b7be0673d18d5a5c571dfc22008992b (diff)
downloadklee-9be96537af07b1f03a55550b932df6f5397c9e6b.tar.gz
Remove support for reporting the approximate git tag.
This was confusing because it would emit something like
`v1.0.0-290-g08d4716` because the 1.1.0 and 1.2.0 releases
didn't have a tag on the master branch so `git describe --tags`
would just find the `v1.0.0` tag and report based on that tag.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48a846fb..581950c7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -624,11 +624,8 @@ if (EXISTS "${CMAKE_SOURCE_DIR}/.git")
   include(${CMAKE_SOURCE_DIR}/cmake/GetGitRevisionDescription.cmake)
   get_git_head_revision(_NOT_USED_KLEE_GIT_REFSPEC KLEE_GIT_SHA1HASH)
   message(STATUS "KLEE_GIT_SHA1HASH: ${KLEE_GIT_SHA1HASH}")
-  git_describe(KLEE_GIT_TAG "--tags")
-  message(STATUS "KLEE_GIT_TAG: ${KLEE_GIT_TAG}")
 else()
   set(KLEE_GIT_SHA1HASH "unknown")
-  set(KLEE_GIT_TAG "unknown")
 endif()
 set(AUTO_GEN_MSG "AUTOMATICALLY GENERATED. DO NOT EDIT!")
 configure_file(${CMAKE_SOURCE_DIR}/include/klee/Config/CompileTimeInfo.h.cmin