about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Nowack <m.nowack@imperial.ac.uk>2020-04-06 14:40:57 +0100
committerCristian Cadar <c.cadar@imperial.ac.uk>2020-11-04 15:14:47 +0000
commita00424e64d56ff881a72bfd99ea0dbcbe6898b49 (patch)
tree5d93c0ec1816011efb2cfaa4c276ef9d94af5a79 /CMakeLists.txt
parentd5cbc2002bbf75f08036f7adf861b027768a0622 (diff)
downloadklee-a00424e64d56ff881a72bfd99ea0dbcbe6898b49.tar.gz
[cmake] Remove clean_all target as not needed by any additional target
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 0 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ec7c1ed..8841e546 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -460,23 +460,6 @@ endif()
 include(${CMAKE_SOURCE_DIR}/cmake/workaround_llvm_pr39177.cmake)
 
 ################################################################################
-# Global clean target
-################################################################################
-# CMake already uses the "clean" target name but it doesn't clean everything
-# unfortunately. We can't modify the target so we provide our own "clean_all"
-# target that runs clean. Other rules for performing clean up should declare
-# that "clean_all" depends on those rules.
-add_custom_target(clean_all
-  # Invoke CMake's own clean target
-  COMMAND
-    "${CMAKE_COMMAND}"
-    "--build"
-    "${CMAKE_BINARY_DIR}"
-    "--target"
-    "clean"
-)
-
-################################################################################
 # KLEE runtime support
 ################################################################################
 # This is set here and not in `runtime` because `config.h` needs to be generated.