about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Nowack <m.nowack@imperial.ac.uk>2018-05-27 14:44:05 +0100
committerCristian Cadar <c.cadar@imperial.ac.uk>2018-07-04 22:14:58 +0100
commita038e4b651434dc57ef355625e7bf7364ded0b5d (patch)
tree269ed5d4c5446a6489df7066a214fc7e213802d1 /CMakeLists.txt
parent54dd6afbae14d4f17a1dee4766331f932d66e117 (diff)
downloadklee-a038e4b651434dc57ef355625e7bf7364ded0b5d.tar.gz
Add missing out-of-tree include files directory for TCMalloc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1beaa30e..6019e428 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -386,6 +386,7 @@ if (ENABLE_TCMALLOC)
         "Found \"${TCMALLOC_HEADER}\" but could not find library")
     endif()
     list(APPEND KLEE_COMPONENT_EXTRA_LIBRARIES ${TCMALLOC_LIBRARIES})
+    list(APPEND KLEE_COMPONENT_EXTRA_INCLUDE_DIRS ${TCMALLOC_INCLUDE_DIR})
     if (("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang") OR ("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU"))
       # TCMalloc's documentation says its safest to pass these flags when
       # building with gcc because gcc can optimize assuming its using its own