about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Liew <daniel.liew@imperial.ac.uk>2017-10-03 11:51:02 +0100
committerDan Liew <daniel.liew@imperial.ac.uk>2017-10-03 11:51:02 +0100
commitb24c543a35512c5a4c8bc6ed18fe3105f0ce4964 (patch)
tree29c98da737709bd4197fdb86dafe7422533fd9b4 /CMakeLists.txt
parent32f65623a0ef117b663fa6ae1a0a93d5f525ee75 (diff)
downloadklee-b24c543a35512c5a4c8bc6ed18fe3105f0ce4964.tar.gz
[CMake] Report the value of some important variables during configure
to aid debugging.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d93de7a..c61c2431 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -621,6 +621,15 @@ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
 set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
 set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
 
+
+################################################################################
+# Report the value of various variables to aid debugging
+################################################################################
+message(STATUS "KLEE_COMPONENT_EXTRA_INCLUDE_DIRS: '${KLEE_COMPONENT_EXTRA_INCLUDE_DIRS}'")
+message(STATUS "KLEE_COMPONENT_CXX_DEFINES: '${KLEE_COMPONENT_CXX_DEFINES}'")
+message(STATUS "KLEE_COMPONENT_CXX_FLAGS: '${KLEE_COMPONENT_CXX_FLAGS}'")
+message(STATUS "KLEE_COMPONENT_EXTRA_LIBRARIES: '${KLEE_COMPONENT_EXTRA_LIBRARIES}'")
+
 ################################################################################
 # KLEE components
 ################################################################################