about summary refs log tree commit diff homepage
path: root/lib/Basic/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Cadar <c.cadar@imperial.ac.uk>2019-08-15 22:32:39 +0100
committerCristian Cadar <c.cadar@imperial.ac.uk>2019-09-03 13:38:23 +0100
commite1f055b1785fd7f23fc4d30eeb0276278892ed20 (patch)
tree7c26a97cc7477dd6a12058826e1ca2495da90529 /lib/Basic/CMakeLists.txt
parentb084092bcc2e5cb69e80a9a0ecd9340ec4c4458c (diff)
downloadklee-e1f055b1785fd7f23fc4d30eeb0276278892ed20.tar.gz
Moved ConstructSolverChain.cpp to the Solver library.
Diffstat (limited to 'lib/Basic/CMakeLists.txt')
-rw-r--r--lib/Basic/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/lib/Basic/CMakeLists.txt b/lib/Basic/CMakeLists.txt
index 78890ea6..d156116f 100644
--- a/lib/Basic/CMakeLists.txt
+++ b/lib/Basic/CMakeLists.txt
@@ -7,7 +7,6 @@
 #
 #===------------------------------------------------------------------------===#
 klee_add_component(kleeBasic
-  ConstructSolverChain.cpp
   KTest.cpp
   Statistics.cpp
 )
@@ -17,12 +16,3 @@ set(LLVM_COMPONENTS
 
 klee_get_llvm_libs(LLVM_LIBS ${LLVM_COMPONENTS})
 target_link_libraries(kleeBasic PUBLIC ${LLVM_LIBS})
-
-target_link_libraries(kleeBasic PRIVATE
-  # FIXME: THIS IS STUPID.
-  # `ConstructSolverChain.cpp` should be in
-  # `kleaverSolver` not in in `kleeBasic`.
-  # We are creating a circular dependency because
-  # of this because `kleaverSolver` depends on `kleeBasic`.
-  kleaverSolver
-)