about summary refs log tree commit diff homepage
path: root/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Liew <daniel.liew@imperial.ac.uk>2017-05-24 17:38:12 +0100
committerDan Liew <delcypher@gmail.com>2017-06-01 11:36:09 +0100
commit31e75fdf1e277bbf961287706b06eab8136c6cd0 (patch)
treed7e845e2b3fbe7c59bb6e5be38ce452c01723ffd /lib/Support/CMakeLists.txt
parent9a73071e22b408bb9bf5c24ec2d7eeb3a8a16e96 (diff)
downloadklee-31e75fdf1e277bbf961287706b06eab8136c6cd0.tar.gz
Refactor file opening code out of `main.cpp` and into
`klee_open_output_file()` function so that it can be used by
the Z3Solver.
Diffstat (limited to 'lib/Support/CMakeLists.txt')
-rw-r--r--lib/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
index 4e44fbc6..7145930f 100644
--- a/lib/Support/CMakeLists.txt
+++ b/lib/Support/CMakeLists.txt
@@ -9,6 +9,7 @@
 klee_add_component(kleeSupport
   CompressionStream.cpp
   ErrorHandling.cpp
+  FileHandling.cpp
   MemoryUsage.cpp
   PrintVersion.cpp
   RNG.cpp