about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 2 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16e33ea9..89054a86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -455,11 +455,6 @@ else()
 endif()
 
 ################################################################################
-# Workarounds
-################################################################################
-include(${CMAKE_SOURCE_DIR}/cmake/workaround_llvm_pr39177.cmake)
-
-################################################################################
 # KLEE runtime support
 ################################################################################
 # This is set here and not in `runtime` because `config.h` needs to be generated.
@@ -612,13 +607,8 @@ if (ENABLE_KLEE_EH_CXX)
   endif()
   message(STATUS "Use libc++abi source path: \"${KLEE_LIBCXXABI_SRC_DIR}\"")
 
-  if (${LLVM_VERSION_MAJOR} GREATER 8 OR ${LLVM_VERSION_MAJOR} EQUAL 8)
-    set(SUPPORT_KLEE_EH_CXX 1) # For config.h
-    message(STATUS "Support for C++ Exceptions enabled")
-  else()
-    set(SUPPORT_KLEE_EH_CXX 0) # For config.h
-    message(STATUS "Support for C++ Exceptions (only available for LLVM >= 8.0.0) disabled")
-  endif()
+  set(SUPPORT_KLEE_EH_CXX 1) # For config.h
+  message(STATUS "Support for C++ Exceptions enabled")
 
 else()
   set(SUPPORT_KLEE_EH_CXX 0) # For config.h