about summary refs log tree commit diff homepage
path: root/runtime/POSIX/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtime/POSIX/CMakeLists.txt')
-rw-r--r--runtime/POSIX/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/runtime/POSIX/CMakeLists.txt b/runtime/POSIX/CMakeLists.txt
new file mode 100644
index 00000000..02d06736
--- /dev/null
+++ b/runtime/POSIX/CMakeLists.txt
@@ -0,0 +1,26 @@
+#===------------------------------------------------------------------------===#
+#
+#                     The KLEE Symbolic Virtual Machine
+#
+# This file is distributed under the University of Illinois Open Source
+# License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+# Set up
+set(LIB_PREFIX "RuntimePOSIX")
+set(SRC_FILES
+        fd.c
+        fd_32.c
+        fd_64.c
+        fd_init.c
+        illegal.c
+        klee_init_env.c
+        misc.c
+        selinux.c
+        stubs.c
+        )
+
+# Build it
+include("${CMAKE_SOURCE_DIR}/cmake/compile_bitcode_library.cmake")
+prefix_with_path("${SRC_FILES}" "${CMAKE_CURRENT_SOURCE_DIR}/" prefixed_files)
+add_bitcode_library_targets("${LIB_PREFIX}" "${prefixed_files}" "-std=gnu89" "")
\ No newline at end of file