about summary refs log tree commit diff homepage
path: root/runtime/klee-eh-cxx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'runtime/klee-eh-cxx/CMakeLists.txt')
-rw-r--r--runtime/klee-eh-cxx/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/runtime/klee-eh-cxx/CMakeLists.txt b/runtime/klee-eh-cxx/CMakeLists.txt
new file mode 100644
index 00000000..e016757b
--- /dev/null
+++ b/runtime/klee-eh-cxx/CMakeLists.txt
@@ -0,0 +1,24 @@
+#===------------------------------------------------------------------------===#
+#
+#                     The KLEE Symbolic Virtual Machine
+#
+# This file is distributed under the University of Illinois Open Source
+# License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+
+set(LIB_PREFIX "eh-cxx")
+set(SRC_FILES
+        klee_eh_cxx.cpp
+        )
+
+set(ADDITIONAL_CXX_FLAGS
+        -nostdinc++
+        -I "${KLEE_LIBCXXABI_SRC_DIR}/src"
+        -I "${KLEE_LIBCXXABI_SRC_DIR}/include"
+        -I "${KLEE_LIBCXX_INCLUDE_DIR}"
+        )
+# Build it
+include("${CMAKE_SOURCE_DIR}/cmake/compile_bitcode_library.cmake")
+prefix_with_path("${SRC_FILES}" "${CMAKE_CURRENT_SOURCE_DIR}/" prefixed_files)
+add_bitcode_library_targets("${LIB_PREFIX}" "${prefixed_files}" "" "${ADDITIONAL_CXX_FLAGS}")
\ No newline at end of file