about summary refs log tree commit diff homepage
path: root/test/Concrete/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/Concrete/CMakeLists.txt')
-rw-r--r--test/Concrete/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/Concrete/CMakeLists.txt b/test/Concrete/CMakeLists.txt
index b3e4948f..7fad17b9 100644
--- a/test/Concrete/CMakeLists.txt
+++ b/test/Concrete/CMakeLists.txt
@@ -6,4 +6,9 @@
 # License. See LICENSE.TXT for details.
 #
 #===------------------------------------------------------------------------===#
+if (${LLVM_VERSION_MAJOR} GREATER 4)
+  set(OZERO_OPT "-Xclang -disable-O0-optnone")
+else()
+  set(OZERO_OPT "-O0")
+endif()
 configure_file(Makefile.cmake.test.in Makefile.cmake.test @ONLY)