about summary refs log tree commit diff homepage
path: root/tools/ktest-randgen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/ktest-randgen/CMakeLists.txt')
-rw-r--r--tools/ktest-randgen/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/ktest-randgen/CMakeLists.txt b/tools/ktest-randgen/CMakeLists.txt
new file mode 100644
index 00000000..8b15c275
--- /dev/null
+++ b/tools/ktest-randgen/CMakeLists.txt
@@ -0,0 +1,17 @@
+#===------------------------------------------------------------------------===#
+#
+#                     The KLEE Symbolic Virtual Machine
+#
+# This file is distributed under the University of Illinois Open Source
+# License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+add_executable(ktest-randgen
+  ktest-randgen.cpp
+)
+
+set(KLEE_LIBS kleeBasic)
+
+target_link_libraries(ktest-randgen ${KLEE_LIBS})
+
+install(TARGETS ktest-randgen RUNTIME DESTINATION bin)