about summary refs log tree commit diff homepage
path: root/unittests/KDAlloc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittests/KDAlloc/CMakeLists.txt')
-rw-r--r--unittests/KDAlloc/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/unittests/KDAlloc/CMakeLists.txt b/unittests/KDAlloc/CMakeLists.txt
new file mode 100644
index 00000000..2bb2ebe8
--- /dev/null
+++ b/unittests/KDAlloc/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_klee_unit_test(KDAllocTest
+  allocate.cpp
+  randomtest.cpp
+  reuse.cpp
+  rusage.cpp
+  sample.cpp
+  stacktest.cpp)
+target_compile_definitions(KDAllocTest PUBLIC "-DKDALLOC_CHECKED" "-DUSE_KDALLOC" "-DUSE_GTEST_INSTEAD_OF_MAIN")
+target_compile_definitions(KDAllocTest PRIVATE ${KLEE_COMPONENT_CXX_DEFINES})
+target_compile_options(KDAllocTest PRIVATE ${KLEE_COMPONENT_CXX_FLAGS})