about summary refs log tree commit diff homepage
path: root/default.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2023-01-26 00:30:53 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2023-01-26 00:54:55 +0900
commitf7720b2207b33fd60ef945662c261c1468e377f7 (patch)
treeb9a05fccca9e8a8a1e5a0fd2d519d0d83f0aa20f /default.nix
parent3f8a9cadb778c7a9aa6e4a396cbb3c5ec34ff409 (diff)
downloadpx-f7720b2207b33fd60ef945662c261c1468e377f7.tar.gz
Add feed and build recipe
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..aba6cf9
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,13 @@
+{ epeg, lib, libxslt, nix-gitignore, stdenvNoCC }:
+stdenvNoCC.mkDerivation rec {
+  pname = "px.cnx.gdn";
+  version = "latest";
+  src = nix-gitignore.gitignoreSource [ ] ./.;
+  makeFlags = [ "PREFIX=$(out)" ];
+  buildInputs = [ epeg libxslt ];
+  enableParallelBuilding = true;
+  meta = {
+    homepage = "https://px.cnx.gdn";
+    license = lib.licenses.cc-by-sa-40;
+  };
+}