about summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2021-10-14 18:43:16 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2021-10-14 18:44:17 +0700
commit2f50663bc527fd2c10e60ca9764e7b0728c97422 (patch)
tree22a3246ecdb123a54da9a4bf20b6e847d18b2892 /pyproject.toml
downloadrsskey-2f50663bc527fd2c10e60ca9764e7b0728c97422.tar.gz
Make it work 0.0.1
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..37b2c79
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,23 @@
+[build-system]
+requires = [ "flit_core >=3.2,<4" ]
+build-backend = "flit_core.buildapi"
+
+[project]
+name = "rsskey"
+version = "0.0.1"
+description = "RSS feed mirror on Misskey"
+readme = "README.md"
+requires-python = ">=3.6"
+license = { file = "COPYING" }
+authors = [ { name = "Nguyễn Gia Phong", email = "mcsinyx@disroot.org" } ]
+maintainers = [ { name = "Nguyễn Gia Phong", email = "mcsinyx@disroot.org" } ]
+keywords = [ "rss", "misskey" ]
+classifiers = [
+    "Development Status :: 5 - Production/Stable",
+    "Intended Audience :: Developers",
+    "License :: OSI Approved :: GNU Affero General Public License v3 or later (AGPLv3+)",
+    "Operating System :: OS Independent",
+    "Programming Language :: Python" ]
+dependencies = [
+    "feedparser", "httpx", "loca", "markdownify", "python-dateutil", "trio" ]
+urls = { project = "https://sr.ht/~cnx/rsskey" }