about summary refs log tree commit diff
path: root/doc/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'doc/shell.nix')
-rw-r--r--doc/shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/doc/shell.nix b/doc/shell.nix
new file mode 100644
index 0000000..453398c
--- /dev/null
+++ b/doc/shell.nix
@@ -0,0 +1,10 @@
+with import <nixpkgs> {};
+mkShell {
+  packages = (with python3Packages; [
+    doit lxml mistune pygments
+  ]) ++ [ nodejs nodePackages.katex ];
+
+  shellHook = ''
+    PYTHONPATH=../src:$PYTHONPATH
+  '';
+}