about summary refs log tree commit diff homepage
path: root/.builds/shell.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2021-12-28 23:13:42 +0700
committerNguyễn Gia Phong <mcsinyx@disroot.org>2021-12-28 23:18:06 +0700
commit89bb239365bdfdef8827251748e6a36d741fdf63 (patch)
tree713c95eaa3beccd0616a1f25753e7dd6b022bf42 /.builds/shell.nix
parentc111dacfdef7624bef023341b6f3a0b88b830ab3 (diff)
downloadsite-89bb239365bdfdef8827251748e6a36d741fdf63.tar.gz
Fix all HTML and RSS compliance issues (hopefully!)
Diffstat (limited to '.builds/shell.nix')
-rw-r--r--.builds/shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/.builds/shell.nix b/.builds/shell.nix
new file mode 100644
index 0000000..3f21d40
--- /dev/null
+++ b/.builds/shell.nix
@@ -0,0 +1,12 @@
+with import <nixpkgs> {};
+mkShell {
+  nativeBuildInputs = [
+    julia-bin nodejs nodePackages.katex
+  ] ++ (with python3Packages; [ bleach markdown ]);
+
+  shellHook = ''
+    npm install highlight.js # https://github.com/NixOS/nixpkgs/issues/152201
+    ln -fns ${nodePackages.katex}/lib/node_modules/katex/dist _libs/katex
+    ln -fs _libs/katex/{fonts,katex.min.css} _css
+  '';
+}