about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
authorNguyễn Gia Phong <mcsinyx@disroot.org>2022-05-05 00:51:08 +0900
committerNguyễn Gia Phong <mcsinyx@disroot.org>2022-05-05 00:52:35 +0900
commit255f3f3a8f584ee3bb8fea298aef4313fdbc1a38 (patch)
tree502cedab075e394b3101de5b62ce246729784ad8 /configuration.nix
parent1399d4a1be1d0c72ef9bc79b32ffc570810273c2 (diff)
downloadnixos-conf-255f3f3a8f584ee3bb8fea298aef4313fdbc1a38.tar.gz
Clean up
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix41
1 files changed, 14 insertions, 27 deletions
diff --git a/configuration.nix b/configuration.nix
index 09039d3..e94e52c 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -68,35 +68,22 @@
 
   time.timeZone = "UTC";
 
-  users = {
-    groups.git = {};
-
-    users = {
-      ckie = {
-        isNormalUser = true;
-        openssh.authorizedKeys.keyFiles = [ "/etc/ssh/ckie.pub" ];
-      };
-
-      cnx = {
-        extraGroups = [ "wheel" ];
-        isNormalUser = true;
-        openssh.authorizedKeys.keyFiles = [ "/etc/ssh/cnx.pub" ];
-        packages = with pkgs; [ stow ];
-      };
+  users.users = {
+    ckie = {
+      isNormalUser = true;
+      openssh.authorizedKeys.keyFiles = [ "/etc/ssh/ckie.pub" ];
+    };
 
-      git = {
-        createHome = true;
-        home = "/var/lib/git";
-        group = "git";
-        isSystemUser = true;
-        openssh.authorizedKeys.keyFiles = [ "/etc/ssh/cnx.pub" ];
-        shell = "${pkgs.git}/bin/git-shell";
-      };
+    cnx = {
+      extraGroups = [ "wheel" ];
+      isNormalUser = true;
+      openssh.authorizedKeys.keyFiles = [ "/etc/ssh/cnx.pub" ];
+      packages = with pkgs; [ stow ];
+    };
 
-      xarvos = {
-        isNormalUser = true;
-        openssh.authorizedKeys.keyFiles = [ "/etc/ssh/xarvos.pub" ];
-      };
+    xarvos = {
+      isNormalUser = true;
+      openssh.authorizedKeys.keyFiles = [ "/etc/ssh/xarvos.pub" ];
     };
   };
 }