about summary refs log tree commit diff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix41
1 files changed, 14 insertions, 27 deletions
diff --git a/configuration.nix b/configuration.nix
index 09039d3..e94e52c 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -68,35 +68,22 @@
 
   time.timeZone = "UTC";
 
-  users = {
-    groups.git = {};
-
-    users = {
-      ckie = {
-        isNormalUser = true;
-        openssh.authorizedKeys.keyFiles = [ "/etc/ssh/ckie.pub" ];
-      };
-
-      cnx = {
-        extraGroups = [ "wheel" ];
-        isNormalUser = true;
-        openssh.authorizedKeys.keyFiles = [ "/etc/ssh/cnx.pub" ];
-        packages = with pkgs; [ stow ];
-      };
+  users.users = {
+    ckie = {
+      isNormalUser = true;
+      openssh.authorizedKeys.keyFiles = [ "/etc/ssh/ckie.pub" ];
+    };
 
-      git = {
-        createHome = true;
-        home = "/var/lib/git";
-        group = "git";
-        isSystemUser = true;
-        openssh.authorizedKeys.keyFiles = [ "/etc/ssh/cnx.pub" ];
-        shell = "${pkgs.git}/bin/git-shell";
-      };
+    cnx = {
+      extraGroups = [ "wheel" ];
+      isNormalUser = true;
+      openssh.authorizedKeys.keyFiles = [ "/etc/ssh/cnx.pub" ];
+      packages = with pkgs; [ stow ];
+    };
 
-      xarvos = {
-        isNormalUser = true;
-        openssh.authorizedKeys.keyFiles = [ "/etc/ssh/xarvos.pub" ];
-      };
+    xarvos = {
+      isNormalUser = true;
+      openssh.authorizedKeys.keyFiles = [ "/etc/ssh/xarvos.pub" ];
     };
   };
 }