summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 18:07:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:19 +0200
commit1655bfb255319b061b57247e7c4ac869d86785d5 (patch)
treebb095882a60079c5f737b311aa0f612d62db3777
parente7493181de029c1bbf94e59a6020e1dce97100ab (diff)
downloadguix-1655bfb255319b061b57247e7c4ac869d86785d5.tar.gz
gnu: Add texlive-context-algorithmic.
* gnu/packages/tex.scm (texlive-context-algorithmic): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 748061c342..c5dbe40fcf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9994,6 +9994,25 @@ for a wealth of support information.")
      "The package deals with accounts of its own specification.")
     (license license:public-domain)))
 
+(define-public texlive-context-algorithmic
+  (package
+    (name "texlive-context-algorithmic")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/context/third/algorithmic/"
+                   "tex/context/third/algorithmic/")
+             (base32
+              "0l2k8a3g3yrirbiwp741h1fisbprhbl2kwzbmd71fij1a80sqfaw")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-context))
+    (home-page "https://ctan.org/pkg/context-algorithmic")
+    (synopsis "Algorithm handling in ConTeXt")
+    (description
+     "This module provides support for typesetting algorithms.")
+    (license license:gpl3+)))
+
 (define-public texlive-beamer
   (package
     (name "texlive-beamer")