summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-08-08 20:00:09 -0500
committerEric Bavier <bavier@member.fsf.org>2017-08-09 01:56:53 -0500
commit2509522c4f4be4491418e65b764862a05444f460 (patch)
tree2c9843faf0dd7609c8a74bc0dc03df579c0f5992
parent9731c412e9ef2fad66181460e768b01cb3c600da (diff)
downloadguix-2509522c4f4be4491418e65b764862a05444f460.tar.gz
gnu: suitesparse: Use modify-phases.
* gnu/packages/maths.scm (suitesparse)[arguments]: Use modify-phases.
-rw-r--r--gnu/packages/maths.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index cc9a9a40a8..5f2697e13c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2448,15 +2448,14 @@ Fresnel integrals, and similar related functions as well.")
              (string-append "INSTALL_INCLUDE="
                             (assoc-ref %outputs "out") "/include"))
        #:phases
-       (alist-cons-before
-        'install 'prepare-out
-        ;; README.txt states that the target directories must exist prior to
-        ;; running "make install".
-        (lambda _
-          (mkdir-p (string-append (assoc-ref %outputs "out") "/lib"))
-          (mkdir-p (string-append (assoc-ref %outputs "out") "/include")))
-        ;; no configure script
-        (alist-delete 'configure %standard-phases))))
+       (modify-phases %standard-phases
+         (delete 'configure)            ;no configure script
+         (add-before 'install 'prepare-out
+           ;; README.txt states that the target directories must exist prior to
+           ;; running "make install".
+           (lambda _
+             (mkdir-p (string-append (assoc-ref %outputs "out") "/lib"))
+             (mkdir-p (string-append (assoc-ref %outputs "out") "/include")))))))
     (inputs
      `(("tbb" ,tbb)
        ("lapack" ,lapack)))