summary refs log tree commit diff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2023-12-27 19:04:58 +0100
committerClément Lassieur <clement@lassieur.org>2024-01-12 18:57:46 +0100
commit2668592d3189efc4271143d05ef70e496717999b (patch)
tree097ab9ec4ba2c6085da1dbfb195bc333ca0c0b9d
parent51891106fa50c07509df9b4d0ef4632e8b685824 (diff)
downloadguix-2668592d3189efc4271143d05ef70e496717999b.tar.gz
gnu: Add go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-lyrebird.
* gnu/packages/golang.scm
(go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-lyrebird):
New variable.

Change-Id: I03b390aa6e8644646622a4f5b89f25e6cd2f7bb0
-rw-r--r--gnu/packages/golang.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d37232faeb..c68f26bf42 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2583,6 +2583,54 @@ Go.")
 Go.")
     (license license:cc0)))
 
+(define-public go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-lyrebird
+  (package
+    (name "go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-lyrebird")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird")
+                    (commit (string-append "lyrebird-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0rifg5kgqp4c3b44j48fjmx00m00ai7fa4gaqrgphiqs1fc5586s"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:unpack-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
+       #:import-path "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird/cmd/lyrebird"
+       #:go ,go-1.20
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'substitutions
+           (lambda _
+             (with-directory-excursion
+                 "src/gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"
+               (for-each
+                (lambda (file)
+                  (substitute* file
+                    (("edwards25519-extra.git") "edwards25519-extra")))
+                (list "common/ntor/ntor_test.go"
+                      "internal/x25519ell2/x25519ell2.go"))
+               (substitute* "internal/x25519ell2/x25519ell2.go"
+                 (("gitlab.com/yawning/obfs4.git")
+                  "gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird"))))))))
+    (propagated-inputs
+     (list go-filippo-io-edwards25519
+           go-github-com-dchest-siphash
+           go-github-com-refraction-networking-utls
+           go-gitlab-com-yawning-edwards25519-extra
+           go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-goptlib
+           go-golang-org-x-crypto
+           go-golang-org-x-net
+           go-golang-org-x-text))
+    (home-page "https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/lyrebird")
+    (synopsis "Look-like nothing obfuscation protocol")
+    (description "This is a look-like nothing obfuscation protocol that
+incorporates ideas and concepts from Philipp Winter's ScrambleSuit protocol.")
+    (license (list license:bsd-2 license:bsd-3))))
+
 (define-public go-github-com-sevlyar-go-daemon
   (package
     (name "go-github-com-sevlyar-go-daemon")