summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-11 22:28:07 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:18 +0800
commit27954c3cb2b771fdd9a8892fed45c1d675f434cc (patch)
tree738d4165d4a33042343b474fe54d482a62f744b1
parentc097775401b35b963a47e7353584906d9dda2782 (diff)
downloadguix-27954c3cb2b771fdd9a8892fed45c1d675f434cc.tar.gz
gnu: Add python-pyproject-hooks.
* gnu/packages/python-xyz.scm (python-pyproject-hooks): New variable.
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 42ab90c608..927c031869 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19315,6 +19315,30 @@ in Python.  It allows you to declare the libraries your project depends on and
 it will manage (install/update) them for you.")
     (license license:expat)))
 
+(define-public python-pyproject-hooks
+  (package
+    (name "python-pyproject-hooks")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pyproject_hooks" version))
+              (sha256
+               (base32
+                "1xaf4sharvacqlav6w3b38nc4j0rzg0p4axi7zamanbzp6cb4wgj"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-flit-core
+           python-testpath
+           python-pytest))
+    (propagated-inputs (list python-tomli))
+    (home-page "https://github.com/pypa/pyproject-hooks")
+    (synopsis "Low-level library for calling @file{pyproject.toml} backends")
+    (description
+     "@code{pyproject-hooks} is a low-level library for calling build backends
+in @file{pyproject.toml}-based projects.  It provides basic functionality to
+write tooling that generates distribution files from Python projects.")
+    (license license:expat)))
+
 (define-public python-lark-parser
   (package
     (name "python-lark-parser")