summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:36 +0200
commit31dbc574d17eef25937cf1daded8bb2750511998 (patch)
tree0fce0216867c1733ca66a1e5ff8caf03650d01dc
parentf36fbb2e537a7e93d38c52ac3b90143ab81207d7 (diff)
downloadguix-31dbc574d17eef25937cf1daded8bb2750511998.tar.gz
gnu: Add texlive-tabfigures.
* gnu/packages/tex.scm (texlive-tabfigures): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 303f8ded65..697d2dc704 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97043,6 +97043,30 @@ environment which does not create this difficulty, so that users need not
 learn two sets of accent commands.")
     (license license:lppl1.0+)))
 
+(define-public texlive-tabfigures
+  (package
+    (name "texlive-tabfigures")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/tabfigures/"
+                   "source/latex/tabfigures/"
+                   "tex/latex/tabfigures/")
+             (base32
+              "18z0w4q5s1pz1r39b6ca8d5l7gp0x9dg9l4b351wsr1jjcci60c0")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tabfigures")
+    (synopsis "Maintain vertical alignment of figures")
+    (description
+     "Knuth designed his original fonts with tabular figures (figures whose width
+is uniform); this makes some layout problems rather simple.  In more recent
+times, fonts (such as Minion Pro), which offer proportionally spaced figures,
+are increasingly being used.  The package provides mechanisms whereby such
+proportional figures may still be aligned in tabular style (for example, in
+the table of contents).")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar