summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 18:08:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:20 +0200
commit3915064ee689ec3ce9bc5e2363101adfbe728491 (patch)
tree99d672a52f87e1bbf28136f88dd43efef84d6e7a
parentded9789bbcfc54ee225e96e494be644b5d144869 (diff)
downloadguix-3915064ee689ec3ce9bc5e2363101adfbe728491.tar.gz
gnu: Add texlive-context-annotation.
* gnu/packages/tex.scm (texlive-context-annotation): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0f12e6b257..975cd785ce 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10034,6 +10034,27 @@ for a wealth of support information.")
 package.")
     (license license:gpl3)))
 
+(define-public texlive-context-annotation
+  (package
+    (name "texlive-context-annotation")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/context/third/annotation/"
+                   "tex/context/interface/third/"
+                   "tex/context/third/annotation/")
+             (base32
+              "1b908rj51dbpicdiwwycb36wscxl1asmsmccrzcfbdji189kf6ck")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-context))
+    (home-page "https://ctan.org/pkg/context-annotation")
+    (synopsis "Annotate text blocks")
+    (description
+     "The @code{annotation} module lets you create your own commands and
+environments to mark text blocks.")
+    (license license:gpl3+)))
+
 (define-public texlive-beamer
   (package
     (name "texlive-beamer")