summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 18:07:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:20 +0200
commitded9789bbcfc54ee225e96e494be644b5d144869 (patch)
treee1e3bd614654b007274acaf13af95c8382396854
parent1655bfb255319b061b57247e7c4ac869d86785d5 (diff)
downloadguix-ded9789bbcfc54ee225e96e494be644b5d144869.tar.gz
gnu: Add texlive-context-animation.
* gnu/packages/tex.scm (texlive-context-animation): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c5dbe40fcf..0f12e6b257 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10013,6 +10013,27 @@ for a wealth of support information.")
      "This module provides support for typesetting algorithms.")
     (license license:gpl3+)))
 
+(define-public texlive-context-animation
+  (package
+    (name "texlive-context-animation")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/context/third/animation/"
+                   "tex/context/interface/third/"
+                   "tex/context/third/animation/")
+             (base32
+              "156zpxjb4c7qaibn7wjw13ysqyqg3m7pb8x3r3fzs6m83gp6r46c")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-context))
+    (home-page "https://ctan.org/pkg/context-animation")
+    (synopsis "Generate fieldstack based animation with ConTeXt")
+    (description
+     "The package is a port, to Context (mkvi), of the corresponding LaTeX
+package.")
+    (license license:gpl3)))
+
 (define-public texlive-beamer
   (package
     (name "texlive-beamer")