summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-24 12:11:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-24 12:49:29 +0100
commit420692482fdcd2488e030d9bdc9b7cc278f665d0 (patch)
tree990d978e0d26995873186d4bd9d7e304d52922e1
parent43a82ad5450a686d2adec99d23f9544a5a1e48cb (diff)
downloadguix-420692482fdcd2488e030d9bdc9b7cc278f665d0.tar.gz
gnu: python-chaospy: Ignore deprecation warnings.
* gnu/packages/statistics.scm (python-chaospy)[arguments]: Add phase
'dont-treat-deprecation-warnings-as-error.

Change-Id: Id06404f9e47f7084fefc2e72032882d49e5b546b
-rw-r--r--gnu/packages/statistics.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d649971839..f4b63247dc 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2250,6 +2250,15 @@ inference (VI) algorithms.")
                (base32
                 "1bn4jmwygs5h0dskbniivj20qblgm75pyi9hcjf47r25kawd730m"))))
     (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          ;; The deprecation warnings break the tests.
+          (add-after 'unpack 'dont-treat-deprecation-warnings-as-error
+            (lambda _
+              (substitute* "pyproject.toml"
+                (("\"error::DeprecationWarning\",") "")))))))
     (propagated-inputs (list python-importlib-metadata python-numpoly
                              python-numpy python-scipy))
     (native-inputs (list python-pytest python-scikit-learn))