summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:58 +0200
commit5401a0247e8d9b9fda7333c2d481923e1fd906d8 (patch)
treef75f03e456d9da6f9582efca9db220d7632fa4bf
parentb5415ca0c87533c904e2da1b3c60795702840cee (diff)
downloadguix-5401a0247e8d9b9fda7333c2d481923e1fd906d8.tar.gz
gnu: Add texlive-selectp.
* gnu/packages/tex.scm (texlive-selectp): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 399af1b7f9..3ac9ceae38 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94968,6 +94968,25 @@ in building indexes with MakeIndex, to deal with repetitions, and to ensure
 page numbers are present in the actual index entries.")
     (license license:lppl1.3+)))
 
+(define-public texlive-selectp
+  (package
+    (name "texlive-selectp")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/selectp/" "tex/latex/selectp/")
+             (base32
+              "1j1i4d5ira8kiqxl24pvlzic8fvvl5zlmsm6wy7hk6z37wp4jmc7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/selectp")
+    (synopsis "Select pages to be output")
+    (description
+     "This package defines a command @code{\\outputonly}, whose argument is a list
+of pages to be output.  With the command present in the header, only those
+pages are output.")
+    (license license:public-domain)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar