summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-08 10:58:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-08 10:58:47 +0300
commit543aab899209e801a23b8cd0e9d9ea154c91136f (patch)
tree57cf6901a5cab65539c16057be299db1ad876b67
parent86fd77476d550796c713d641b8d2397f2f31676e (diff)
downloadguix-543aab899209e801a23b8cd0e9d9ea154c91136f.tar.gz
gnu: p7zip: Remove input labels.
* gnu/packages/compression.scm (p7zip)[native-inputs]: Rewrite using
target macros and remove labels.
-rw-r--r--gnu/packages/compression.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index b68bb7a002..975d2da16b 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1350,13 +1350,11 @@ for most inputs, but the resulting compressed files are anywhere from 20% to
                (invoke "make" "test_7z")
                (invoke "make" "test_7zr")))))))
     (native-inputs
-     (let ((system (or (%current-target-system)
-                       (%current-system))))
-       `(,@(cond ((string-prefix? "x86_64" system)
-                  `(("yasm" ,yasm)))
-                 ((string-prefix? "i686" system)
-                  `(("nasm" ,nasm)))
-                 (else '())))))
+      (cond ((target-x86-64?)
+             (list yasm))
+            ((target-x86-32?)
+             (list nasm))
+            (else '())))
     (home-page "http://p7zip.sourceforge.net/")
     (synopsis "Command-line file archiver with high compression ratio")
     (description "p7zip is a command-line port of 7-Zip, a file archiver that