summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-04-02 22:34:21 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-02 23:16:30 +0200
commit576f245c2d65f8a665ddc6936f229a669fbc4597 (patch)
tree65a5161290191b5a2a484f8e5cac7bce04c208dd
parent2a27c0bbb896fb097cf18cb08bafc70dbaf68e2d (diff)
downloadguix-576f245c2d65f8a665ddc6936f229a669fbc4597.tar.gz
gnu: guile-git: Update to 36f93c1.
* gnu/packages/guile.scm (guile-git): Update to 36f93c1.
-rw-r--r--gnu/packages/guile.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index aa71fa1410..6efa0dd96a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1933,8 +1933,8 @@ is not available for Guile 2.0.")
     (license license:lgpl3+)))
 
 (define-public guile-git
-  (let ((revision "5")
-        (commit "2bb9fbbf93cf93496718efc85ad9394aefa21029"))
+  (let ((revision "6")
+        (commit "36f93c174adc396c90ec3a6923487f0444fe5d69"))
     (package
       (name "guile-git")
       (version (string-append "0.0-" revision "." (string-take commit 7)))
@@ -1944,7 +1944,7 @@ is not available for Guile 2.0.")
                 (uri (git-reference (url home-page) (commit commit)))
                 (sha256
                  (base32
-                  "0z3v0v89dyp35zx2h2gsq6v29lba3wbzabc5n2g4hx2fcb6q5qqy"))
+                  "0z1dvn0scx59pbgjkpacam7p5n7630z4qm8fazim7ixq9xv3s8wx"))
                 (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
@@ -1955,7 +1955,8 @@ is not available for Guile 2.0.")
 
                     ;; FIXME: On i686, bytestructures miscalculates the offset
                     ;; of the 'old-file' and 'new-file' fields within the
-                    ;; '%diff-delta' structure.
+                    ;; '%diff-delta' structure.  See
+                    ;; <https://github.com/TaylanUB/scheme-bytestructures/issues/30>.
                     ,@(if (string=? (%current-system) "x86_64-linux")
                           '()
                           '((add-before 'check 'skip-tests