summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-03-17 23:08:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-03-17 23:15:34 +0200
commit5983b78368f1033c52cc5e824115975ab0b31dff (patch)
treea8c0d47049bf72baca40f5253f697ea4bd36b417
parent308b17f676999876bfec12841659cbfa56a652be (diff)
downloadguix-5983b78368f1033c52cc5e824115975ab0b31dff.tar.gz
gnu: shaderc: Clean up package arguments.
* gnu/packages/vulkan.scm (shaderc)[version]: Remove extra '-'.
[arguments]: Remove extra 'mkdir-p' calls and refer to inputs directly.
-rw-r--r--gnu/packages/vulkan.scm21
1 files changed, 7 insertions, 14 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index bd0fb9e1ce..12b1f93015 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -212,7 +213,7 @@ and the ICD.")
         (revision "1"))
     (package
       (name "shaderc")
-      (version (git-version "0.0.0-" revision commit))
+      (version (git-version "0.0.0" revision commit))
       (source
        (origin
          (method git-fetch)
@@ -254,22 +255,14 @@ and the ICD.")
                                         out)))))
            (add-after 'unpack 'unpack-sources
              (lambda* (#:key inputs #:allow-other-keys)
-               (let ((spirv-tools-source (assoc-ref %build-inputs
-                                                    "spirv-tools-source"))
-                     (spirv-headers-source (assoc-ref %build-inputs
-                                                      "spirv-headers-source"))
-                     (glslang-source (assoc-ref %build-inputs
-                                                "glslang-source")))
-                 (mkdir-p "third-party/spirv-tools")
-                 (copy-recursively spirv-tools-source
-                                   "third_party/spirv-tools")
-                 (mkdir-p "third-party/spirv-tools/external/spirv-headers")
+               (let ((spirv-tools-source (assoc-ref inputs "spirv-tools-source"))
+                     (spirv-headers-source (assoc-ref inputs "spirv-headers-source"))
+                     (glslang-source (assoc-ref inputs "glslang-source")))
+                 (copy-recursively spirv-tools-source "third_party/spirv-tools")
                  (copy-recursively spirv-headers-source
                                    (string-append "third_party/spirv-tools"
                                                   "/external/spirv-headers"))
-                 (mkdir-p "third-party/glslang")
-                 (copy-recursively glslang-source
-                                   "third_party/glslang")
+                 (copy-recursively glslang-source "third_party/glslang")
                  #t))))))
       (inputs
        `(("python" ,python)))