summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-07-11 00:39:19 +0100
committerAndreas Enge <andreas@enge.fr>2023-07-26 15:33:27 +0200
commit6397f1326df8beb68383147cef55728ca876ee7a (patch)
treeccf94d16bcd810a8e397dc87ee9f9e28e8135b39
parente05dcecd0df49a397aba49585a626cae16a6306c (diff)
downloadguix-6397f1326df8beb68383147cef55728ca876ee7a.tar.gz
gnu: Add ccfits.
* gnu/packages/astronomy.scm (ccfits): New variable.

Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/astronomy.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1ff6cb9892..65799ef463 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -420,6 +420,30 @@ made to get a better separation of core libraries and applications.
 @url{https://casa.nrao.edu/, CASA} is now built on top of Casacore.")
     (license license:gpl2+)))
 
+(define-public ccfits
+  (package
+    (name "ccfits")
+    (version "2.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://heasarc.gsfc.nasa.gov/docs/software/fitsio/ccfits/"
+             "CCfits-" version ".tar.gz"))
+       (sha256
+        (base32 "04l6na8vr5xadz3rbx62as79x1ch4994vbb625kx0dz5czdkkd1b"))))
+    (build-system cmake-build-system)
+    (inputs (list cfitsio))
+    (home-page "https://heasarc.gsfc.nasa.gov/docs/software/fitsio/ccfits/")
+    (synopsis "C++ interface to the CFITSIO")
+    (description
+     "CCfits is an object oriented interface to the cfitsio library.  It is
+designed to make the capabilities of cfitsio available to programmers working in
+C++.  It is written in ANSI C++ and implemented using the C++ Standard Library
+with namespaces, exception handling, and member template functions.")
+    (license (license:non-copyleft "file://License.txt"
+                                   "See License.txt in the distribution."))))
+
 (define-public cfitsio
   (package
     (name "cfitsio")