summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:58 +0200
commit659bb9a7b32ad131d2336cb040f356ee7aba6c1d (patch)
treec573c0184e311d12687e675bb875807e87fa5dd8
parent5401a0247e8d9b9fda7333c2d481923e1fd906d8 (diff)
downloadguix-659bb9a7b32ad131d2336cb040f356ee7aba6c1d.tar.gz
gnu: Add texlive-semantex.
* gnu/packages/tex.scm (texlive-semantex): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3ac9ceae38..9e48ee4ae7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94987,6 +94987,31 @@ of pages to be output.  With the command present in the header, only those
 pages are output.")
     (license license:public-domain)))
 
+(define-public texlive-semantex
+  (package
+    (name "texlive-semantex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/semantex/" "tex/latex/semantex/")
+             (base32
+              "0pjx6ff628bwa027vrcjx1x9vg967mh22vb7sy3pdxdk1mx0idhn")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-semtex))
+    (home-page "https://ctan.org/pkg/semantex")
+    (synopsis "Semantic, keyval-based mathematics")
+    (description
+     "The SemanTeX package for LaTeX delivers a more semantic,
+systematized way of writing mathematics, compared to the classical math syntax
+in LaTeX.  The system uses keyval syntax, and the user can define their own
+keys and customize the system down to the last detail.  At the same time, care
+has been taken to make the syntax as simple, natural, practical, and
+lightweight as possible.  Furthermore, the package has a companion package,
+called @code{stripsemantex}, which allows you to completely strip your
+documents of SemanTeX markup to prepare them e.g., for publication.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar