summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-07-25 21:35:35 +0200
committerAlex Kost <alezost@gmail.com>2015-07-31 10:59:31 +0300
commit670398751e982bfc17cc6c1f2bf155a9ca7c9bce (patch)
treefef54ac32744f29d3393a17754f8487c0fa88583
parent52323f32fa3d5c93249b7d76f9c7a1f1e906c86b (diff)
downloadguix-670398751e982bfc17cc6c1f2bf155a9ca7c9bce.tar.gz
gnu: Add python-ecdsa.
* gnu/packages/python.scm (python-ecdsa, python2-ecdsa): New variables.

Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/python.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a3802a42e0..817b6cdd1b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,40 @@ pidof, tty, taskset, pmap.")
 (define-public python2-psutil
   (package-with-python2 python-psutil))
 
+(define-public python-ecdsa
+  (package
+    (name "python-ecdsa")
+    (version "0.13")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/e/ecdsa/ecdsa-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1yj31j0asmrx4an9xvsaj2icdmzy6pw0glfpqrrkrphwdpi1xkv4"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (inputs
+     `(("openssl" ,openssl)))
+    (home-page
+     "http://github.com/warner/python-ecdsa")
+    (synopsis
+     "ECDSA cryptographic signature library (pure python)")
+    (description
+     "This is an easy-to-use implementation of ECDSA cryptography (Elliptic
+Curve Digital Signature Algorithm), implemented purely in Python.  With this
+library, you can quickly create keypairs (signing key and verifying key), sign
+messages, and verify the signatures.  The keys and signatures are very short,
+making them easy to handle and incorporate into other protocols.")
+    (license license:expat)))
+
+(define-public python2-ecdsa
+  (package-with-python2 python-ecdsa))
+
 (define-public python-ccm
   (package
     (name "python-ccm")