summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:58:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:06 +0200
commit68800cdd520fbda8283f7eedf37b62afa84ae6d4 (patch)
tree8144d348ea94baa6c1945649b8f584bbf311a07c
parentf9dd940ea92d45b6574d6c78c01165e13932655a (diff)
downloadguix-68800cdd520fbda8283f7eedf37b62afa84ae6d4.tar.gz
gnu: Add texlive-phfcc.
* gnu/packages/tex.scm (texlive-phfcc): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 229cb0ca94..0e2298f38c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -92125,6 +92125,30 @@ again.  This way the functions should be usable in every @code{pgfmath}
 context, though there is some overhead to this approach.")
     (license license:lppl1.3c)))
 
+(define-public texlive-phfcc
+  (package
+    (name "texlive-phfcc")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/phfcc/" "source/latex/phfcc/"
+                   "tex/latex/phfcc/")
+             (base32
+              "04i0srq2ps4l8vbacci3ipdw4mc4hccwzp03lxj4b4a874yxdhg6")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/phfcc")
+    (synopsis "Convenient inline commenting in collaborative documents")
+    (description
+     "This packages allows one to easily define helper macros to insert comments in
+a LaTeX document.  A convenient syntax enables you to mark text
+additions (e.g., @samp{\\phf@{I'm adding this text@}}), an in-line
+comment (e.g., @samp{We're the best \\phf[I'm not sure about this.]}), and
+text removals (e.g., @samp{\\phf*@{remove me@}}).  New colors are assigned
+automatically to each commenter by default, and the appearance of all comments
+is highly customizable.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar