summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-12 23:35:08 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-24 21:54:32 +0200
commit6eceb2d44529851e223f507d6e52f56ad3b7b1ee (patch)
treedb7cd943ecbac02d51f6baa4325548a3678342c5
parent72f278a0ff1776a6ad599b9b0f64f87207481398 (diff)
downloadguix-6eceb2d44529851e223f507d6e52f56ad3b7b1ee.tar.gz
gnu: Add python-sphinxcontrib-qthelp.
* gnu/packages/sphinx.scm (python-sphinxcontrib-qthelp): New public variable.
-rw-r--r--gnu/packages/sphinx.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 3fd4a399c3..0090ddbddd 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -233,6 +233,26 @@ commands into documents, helping you to keep your command examples up to date.")
 (define-public python2-sphinxcontrib-programoutput
   (package-with-python2 python-sphinxcontrib-programoutput))
 
+(define-public python-sphinxcontrib-qthelp
+  (package
+    (name "python-sphinxcontrib-qthelp")
+    (version "1.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "sphinxcontrib-qthelp" version))
+              (sha256
+               (base32
+                "0vs09m6kf5vhiivpi5s5pks59iq0lqlsbkdycpqlysg53bhmqikr"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f))                    ;XXX: circular dependency on Sphinx
+    (home-page "https://github.com/sphinx-doc/sphinxcontrib-qthelp")
+    (synopsis "Sphinx extension to output QtHelp documents")
+    (description
+     "@code{sphinxcontrib-qthelp} is a Sphinx extension which outputs QtHelp
+documents.")
+    (license license:bsd-2)))
+
 (define-public python-sphinxcontrib-serializinghtml
   (package
     (name "python-sphinxcontrib-serializinghtml")