summary refs log tree commit diff
diff options
context:
space:
mode:
authorEdward Wilson <bienjensu@gmail.com>2024-01-24 22:34:40 +0000
committerAndrew Tropin <andrew@trop.in>2024-01-26 19:39:31 +0300
commit8ae8b9804fa4aef23d4028563559bf7bec52fec2 (patch)
tree0e441a306168a1e9dfc3669e647baa71426feaeb
parent467192552859f8637a83304c1b101ed440de24e3 (diff)
downloadguix-8ae8b9804fa4aef23d4028563559bf7bec52fec2.tar.gz
gnu: emacs-citar: Fix autoloads and restore tests.
The default build-system emacs doesn't properly expand cl-lib macros when
compiling autoloads. This patch changes the `#:emacs` build argument, fixing a
present bug (reproducible by requiring citar-autoloads in a minimal
environment). This change also allows the validation of compiled autoloads to
succeed, hence the test phase is restored.

* gnu/packages/emacs-xyz.scm (emacs-citar): Change build-system emacs and
restore tests

Change-Id: Id56de922e5220383f8c5015a01e39b4aa2ea8cfb
Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/emacs-xyz.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7d3e2dc17e..561f41cccf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23634,6 +23634,7 @@ automatically fetched from well-curated sources, and formatted as BibTeX.")
     (build-system emacs-build-system)
     (arguments
      (list
+      #:emacs emacs-no-x
       #:tests? #true
       #:test-command #~(list "emacs" "--batch" "-L" "."
                              "-l" "test/citar-test.el"
@@ -23643,10 +23644,7 @@ automatically fetched from well-curated sources, and formatted as BibTeX.")
       #:phases #~(modify-phases %standard-phases
                    (add-before 'build 'set-home
                      (lambda _
-                       (setenv "HOME" "/tmp")))
-                   ;; XXX: The following phase reports bogus errors. Suppress
-                   ;; it for now.
-                   (delete 'validate-compiled-autoloads))))
+                       (setenv "HOME" "/tmp"))))))
     (propagated-inputs (list emacs-auctex
                              emacs-citeproc-el
                              emacs-embark