summary refs log tree commit diff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2022-08-25 20:47:32 +0200
committerMarius Bakke <marius@gnu.org>2022-08-29 18:22:59 +0200
commit9529384c92e6427e7d277ffaa391405ef6ab22f3 (patch)
treed5adbe7f578e5a2ebf5be81b41f254fbb8791bf5
parent6a31fb6e7b2bc6daba973d440ea4480d57ee6597 (diff)
downloadguix-9529384c92e6427e7d277ffaa391405ef6ab22f3.tar.gz
gnu: snakemake-7: Convert dependencies to propagated-inputs
* gnu/packages/python-xyz.scm (snakemake-7)[inputs]: Change to ...
[propagated-inputs]: ... this, to ensure that "python -m snakemake"
works (because snakemake uses it internally).

Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a8248e3ec8..f58677993c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9758,7 +9758,7 @@ Python style, together with a fast and comfortable execution environment.")
                ;; to the Google Storage service.
                (delete-file "tests/test_google_lifesciences.py")
                (invoke "pytest")))))))
-    (inputs
+    (propagated-inputs
      (list python-appdirs
            python-configargparse
            python-connection-pool